XXILINX®
EDK 7.1 PowerPC Tutorial in Virtex-4

Objectives

This tutorial will demonstrate process of creating and testing a PowerPC system design using the Embedded
Development Kit (EDK). The tutorial contains these sections:

e System Requirements
e PowerPC System Description

e Tutorial Steps

The following steps are described in this tutorial:
e Starting XPS
e Using the Base System Builder Wizard
e  Create — Import IP Peripheral
e Design Modification using Platform Studio
e Implementing the Design
e Defining the Software Design
e Downloading the Design
e Debugging the Design

e Performing Behavioral Simulation of the Embedded System

System Requirements

You must have the following software installed on your PC to complete this tutorial:
e  Windows 2000 SP2/Windows XP

Note: This tutorial can be completed on Linux or Solaris, but the screenshots and directories illustrated in
this tutorial are based on the Windows Platform.

e EDK 7.1i SP1 or later
e ISE 7.1i SP1 or later

In order to download the completed processor system, you must have the following hardware:
e Xilinx ML403 Evaluation Platform (XC4FX12 FF668)
e Xilinx Parallel -4 Cable used to program and debug the device
e Serial Cable

Note: It should be noted that other hardware could be used with this tutorial. However, the completed design
has only been verified on the board specified above. The following design changes are required:

¢ Update pin assignments in the system.ucf file

¢ Update board JTAG chain specified in the download.cmd
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PowerPC System Description

In general, to design an embedded processor system, you need the following:

e Hardware components

e Memory map

e Software application

Tutorial Design Hardware

The PowerPC (PPC) tutorial design includes the following hardware components:

e PowerPC
e PLB Bus

¢ PLB_BRAM_IF_CNTLR

¢ BRAM_BLOCK
¢ PLB_EMC

¢ PLB20OPB_Bridge

e  On-chip Peripheral Bus (OPB) BUS

¢ OPB_UARTLITE

¢ 2 -OPB_GPIOs

Tutorial Design Memory Map

The following table shows the memory map for the tutorial design as created by Base System Builder.

Device . Address Size Comment
Min Max
PLB_BRAM_CNTLR OxFFFF_8000 OxFFFF_FFFF 32K bytes PLB Memory
OPB_UARTLITE 0x4060_0000 0x4060_FFFF 64K bytes Serial Output
OPB_GPIO 0x4002_0000 0x4002_FFFF 64K bytes LED output
OPB_GPIO 0x4000_0000 0x4000_FFFF 64K bytes Push Buttons
PLB_EMC 0x0000_0000 0x0000_FFFF 1M bytes External Memory Controller

Table 1: Tutorial Design Memory Map
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Tutorial Steps

SetUp

e ML403 board with a RS-232 terminal connected to the serial port and configured for 57600 baud, with 8
data bits, no parity and no handshakes.

Creating the Project File in XPS
The first step in this tutorial is using the Xilinx Platform Studio (XPS) to create a project file. XPS allows you to
control the hardware and software development of the PowerPC system, and includes the following:

e An editor and a project management interface for creating and editing source code

e Software tool flow configuration options

You can use XPS to create the following files:
e Project Navigator project file that allows you to control the hardware implementation flow
e  Microprocessor Hardware Specification (MHS) file

Note: For more information on the MHS file, refer to the “Microprocessor Hardware Specification (MHS)”
chapter in the Embedded System Tools Guide.

e  Microprocessor Software Specification (MSS) file

Note: For more information on the MSS file, refer to the “Microprocessor Software Specification (MSS)”
chapter in the Embedded System Tools Guide.

XPS supports the software tool flows associated with these software specifications. Additionally, you can use XPS to
customize software libraries, drivers, and interrupt handlers, and to compile your programs.

l. Starting XPS

To open XPS, select the following:
Start » Programs = Xilinx Platform Studio 7.1i » Xilinx Platform Studio

Select Base System Builder Wizard (BSB) to open the Create New Project Using BSB Wizard dialog
box shown in Figure 1.

Click Ok.

Use the Project File Browse button to browse to the folder you want as your project directory.
Click Open to create the system.xmp file.

Click Ok to start the BSB wizard.

Note: XPS does not support directory or project names which include spaces.

PowerPC Tutorial www.xilinx.com 3
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ssin it

The project file will be created in the curent directary if a path iz not specified.

New.PrDiect

Project File D:APPC_tutarialapstern smp Browse ...

J

Peripheral B epogitary Directary [Advanced Ophion]

[ User Perpheral Bepositony search path for P, diver and libran files.
Can be a semicolon separated hst of directonies.

|

ok | Cancel |

Figure 1: Create New Project Using Base System Builder Wizard

Defining the System Hardware
Il. MHS and MPD Files

The next step in the tutorial is defining the embedded system hardware with the Microprocessor Hardware
Specification (MHS) and Microprocessor Peripheral Description (MPD) files.

MHS File

The Microprocessor Hardware Specification (MHS) file describes the following:

e Embedded processor: either the soft core MicroBlaze processor or the hard core PowerPC (only available in
Virtex-II Pro devices)

e Peripherals and associated address spaces
e Buses

e  Overall connectivity of the system

The MHS file is a readable text file that is an input to the Platform Generator (the hardware system building tool).
Conceptually, the MHS file is a textual schematic of the embedded system. To instantiate a component in the MHS
file, you must include information specific to the component.

MPD File

Each system peripheral has a corresponding MPD file. The MPD file is the symbol of the embedded system
peripheral to the MHS schematic of the embedded system. The MPD file contains all of the available ports and
hardware parameters for a peripheral. The tutorial MPD file is located in the following directory:

$XILINX_EDK/hw/XilinxProcessorIPLib/pcores/<peripheral_name>/data

Note: For more information on the MPD and MHS files, refer to the “Microprocessor Peripheral Description
(MPD)” and “Microprocessor Hardware Specification (MHS)” chapters in the Embedded System Tools Guide.

EDK provides two methods for creating the MHS file. Base System Builder Wizard and the Add/Edit Cores Dialog
assist you in building the processor system, which is defined in the MHS file. This tutorial illustrates the Base System
Builder.
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lll.  Using the Base System Builder Wizard

Use the following steps to create the processor system:

In the Base System Builder — Select “I would like to create a new design”.

In the Base System Builder - Select Board Dialog select the following, as shown in Figure 2:

e Board Vendor: Xilinx

e Board Name:  Virtex 4 ML403 Evaluation Platform

e Board Revision: 1

Base System Builder - Select Board

Select a target development board:

it | would like to create a zuztem for the following development board

Board Wendar |><ilim-c

Board Mame |Virte:-: 4 WL403 Evaluation Platform

Board Revizion | 1

Wendor's Website Contact [nfo

Drownload Third Party Board Definition Files

Board Description

kare Infa

i | would like to create a spstem for a custom board

The MLA03 board iz intended to showcase and demonztrate VWitex-4 technology,
ezpecially the new features being added to the FPGA. The ML403 board utiizes
Hiline Wirkew 4 XAV 2-FFEES device. It iz a demonsztration platfarmm ta
showecase the enormous power and flexibilig of Yirtex-4 FPGAs including new
and improved clock technology, DSP blocks, Smart BaM blocks, advanced |
|0z, embedded MACs, embedded processarz, and mare.

< Back | Mest » |

Ll Led Lo

Cancel

X]

Figure 2: BSB: Select a Board

Click Next. Verify that PowerPC is selected.

Click Next. You will now specify several processor options as shown in Figure 3:

PowerPC Tutorial
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Base System Builder - Configure Processor @

WIRTEXCI
PRC
Powerf{"
System Wide Settings
Reference Clock Processor Clock Bus Clock
Frequency: Frequency: Frequency:
100.00 MHz 300.00 - | MHz 10000 - | MHz

Enzure that pour board is configured for the specifed frequency.
Feszet Palarity | J

PowerPC 405 Proceszor Engine
JTAG Debug Interface
v FPGAJTAG
" CPU Debug User Pins Orly

~
- On-Chip Memary [OCk]
Spebig [Uses BRAM)
: Data:

HOME -
mp{m """" [nztruchion:

HOME -

Cache
| Enabled

¢ Back M et > Cancel

Figure 3: Configure Processor

The following is an explanation of the settings specified in Figure 3:
e System Wide Setting:
¢ Processor Clock Frequency: This is the frequency of the clock driving the processor system.

¢ Bus Clock Frequency: This is the frequency of the clock driving the PLB, OPB, and OCM buses.
e Processor Configuration:

¢ JTAG Debug Interface:

¢ FPGA JTAG: The PowerPC JTAG pins will be included in the FPGA JTAG chain.

¢ CPU Debug User Pins Only: This will bring the PowerPC JTAG pins out to user IO.
¢

CPU Debug User and Trace Pins: This option is unavailable because the ML403 board does not have a
separate trace header.

¢ No Debug: No debug is turned on.

www.xilinx.com EDK 7.1 PowerPC Tutorial in Virtex-4
1-800-255-7778 WTO001 (v3.0) April 1, 2005



EDK 7.1 PowerPC Tutorial in Virtex 4Virtex-4 STXILINX

Note: For more information about the Xilinx Microprocessor Debugger (XMD), refer to the Xilinx
Microprocessor Debugger (XMD) chapter in the Embedded System Tools Guide.

e Users can also specify the size of the On-Chip Memory.

e You can also specify the use of a cache.

Click Next. Select the peripheral subset as shown in Figure 4 and Figure 5.

Note: The Baudrate for the OPB UARTLITE must be updated to 57600.

Base System Builder, - Configure 10 Interfaces ﬁ]

The following external memon and [0 interfaces were found on wour target board;

siline Virke 4 bLAO3 Evaluation Platform Fevizion 1
Fleaze select the 10 interfaces or portz vihich vou would like bo uze;
|0 Devices

W R5232_Uart

Ferpheral: | OPE UARTLITE -
Baudiate (Bit:  [57e00

per geconds):

[rata Bits: 3 -
Parity: NOME =

Data Sheet

i

[T Uze Intermupt

- )

W LEDs 48t w
Feripheral: | 0P GFIO &

[ Usze Intemupt

I LEDs_Positions

N

i

v Push_Buttons_Pasition

Feripheral: |OPE GFIO -

[ Usze Interrupt

Data Sheet

i

[ IIC_EEPROM

N

i

tare Info < Back | Mext » | Cancel

Figure 4: Peripheral Selection
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Base System Builder - Configure Additional IO Interfaces

The following external memory and 10 interfaces were found on pour target board:

Hilire Wirtex 4 MLA03 Evaluation Platform B evigion 1
Pleaze select the |0 interfaces or ports which you wauld like bo use:
10 Devices

[ SpsACE_CompactFlash

S

[ DDR_SDRAM_Edhix32

S

[ Ethermet_MAC

S,

EEE L

Iv SRab_256K<32

Peripheral: |PLE EMC -

Data Sheet

[ FLASH_2Mx32

S

!

tare Info < Back | Mest = | Canicel

Figure 5: Peripheral Selection

Click Next through the Configure IO Interface pages.

On the Add Internal Peripherals page, select 32 KB of memory for the PLB BRAM IF CNTLR. This
completes the hardware specification and we will now configure the software settings.

Click Next. Using the Software Setup dialog box as shown in Figure 6, specify the following software
settings:

o Standard Input (STDIN) - RS232

o Standard Output (STDOUT) - RS232

www.xilinx.com EDK 7.1 PowerPC Tutorial in Virtex-4
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o Sample Application Selection - Memory Test

o Sample Application Selection - Peripheral Self Test

Base System Builder - Software Setup g|

Devices to use as Standard [nput and Standard Output

STDIM

sTDOUT  [Rszaz_uar |

Sample Application Selection

Select the zample C application that you would like to have generated.
Each application will include a linker script.

v Memary Test

luztrate system aliveness and perform a bagic readwrite test to
each memaory in your system

[v Peripheral SelfT est

Perform a simple zelf-test for each peripheral in your system

More Info < Back | MHexst » | Cancel

Figure 6: Software Configuration

Click Next.
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Base System Builder - Configure Memory Test Application

The zsimple Memony Test application will illustrate spstem aliveness and perform
a baszic readwrite test to vour memorny devices.

MemomT ezt
Select the memary devices which will be used to hold the fallowing
program gections:

Invstruictions: plb - bram_if_cntl_1

Data: |p||:|_|:|ram_i[_cntll_1 ﬂ
|

Stack/Heap: |p|b_bram_if_cntlr_1

WwaRNING
If you have placed the |nstiuction or D'ata section of thiz program in an
external memory, you must use a debugger, bootloader, or ACE file to
initialize memory before you can wn this program!

M ore [nfo ¢ Back | et » | Cancel |

Figure 7: Configure Memory Test Application
Using the Configure Memory Test Application dialog box as shown in Figure 7, specify the
following software settings:
o Instructions - plb_bram_if cntlr_1
o Data - plb_bram_if cntlr_1

o Stack/Heap - plb_bram_if cntlr_1

EDK 7.1 PowerPC Tutorial in Virtex-4
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Click Next. Using the Configure Peripheral Test Application specify the following software settings:
o Instructions » SRAM_256Kx32
o Data » SRAM_256Kx32
o Stack/Heap -> SRAM_256Kx32

Click Next. The completed system including the memory map will be displayed as shown in Figure

8. Currently the memory map cannot be changed or updated in the BSB. If you want to change the
memory map you can do this in XPS.

Base System Builder - System Created §|

Below iz a summary of the spatem pou have created. Please review the information below. IF
it iz carrect, hit <Generates ta enter the infarmation inta the =<P5 data baze and generate the
apztem filez. Othenmize return to the previous page to make comections.

Processor PPC 405 A
Proceszar clock frequency: 300000000 MHz

Bz clock frequency: 100000000 MHz

Debug interface: FRGEA JTAG

On Chip Memon . 32 KB

Total OFf Chip Memory . 1 MB W

The addrezs mapz below have been automatically azsigned. v'ou can modify them
uzing the editing features of <P5.

PLB Bus : PLE_¥34 Inst. name: plb  Attached Components:

Care Mame Inztance Mame Baze Addr High Addr

plb2opb_bridge plbZopb_C_RMGO_ 0x40000000 0«7FFFFFFF
plb_ermc SRAM_256kx32  Ox00000000 0«000FFFFF
plb_bram_if_cntk  plb_bram_if_cntl 1 O=FFFFE000 0«FFFFFFFF

OPE Bus : OPB_¥20 Inst. name: opb Altached Components: |

Core Mame Instance Mame Bage Addr High Addr

opb_uartlite RS232_Uart 040800000 0x4060FFFF
opb_gpio LED: 4Bt 0x40020000 0x4002FFFF
opb_gpio Puzh_Buttonz_Posit 0x40000000 0=4000FFFF

< Back | Generate | Cancel

Figure 7: Completed Processor System
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Click Generate and then Finish to complete the design.

Select Start Using Plarform Studio and click OK.

Review

The Base System Builder Wizard has created the hardware and software specification files that define the processor
system. When we look at the project directory, shown in Figure 8, we see these as system.mhs and system.mss.
There are also some directories created.

e data — contains the UCF (user constraints file) for the target board.

e etc — contains system settings for JTAG configuration on the board that is used when downloading the bit
file and the default parameters that are passed to the ISE tools.

e pcores — is empty right now, but is utilized for custom peripherals.

e TestApp_Memory — contains a user application in C code source, for testing the memory in the system.

Marne

| Today

|idata

et

| Ciprores

| ) Testapp_Memory
syskern, bsh

El syskem.log
system.mhs
syskem. mss

system.xmp

£

Size

3KB
1KE
7KE
ZKE
1KB

Tvpe

File Folder

Filz Folder

File Folder

File Folder

BSE File

Text Document
MHS File

M35 File

#MP File

?

Figure 8: Project Directory after Base System Builder completes
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Project Options
Base System Builder has also already configured the project settings for us, but take a moment to look at what they

are.
select: Options > Project Options. As shown in Figure 9, the device information is specified.

Project Options §|

Device and Repository l Hierarchy and Flow | HOL and Simulation |
Target Device
Architecture Device Size Package (Grade

lviterd ¥ | |wcavi12 | |fie68 w| |10 =]

Peripheral Bepogsitary Directary [Advanced Option]

| |

[f you changed the Peripheral Bepozitany directany,
wou will need to zave the project, cloze it and load it again.

Cuztom Makefile [Advanced Ophion)
Specify Makefile to uze instead of %P5 generated Makefile.

|

M ate: =PS will ovensrite any custom makefile that is named
the same az the *FS generated makefile

| k. | Cancel | Help |

Figure 9: Project Options - Device and Repository

Select: Hierarchy and Flow. This window is shown in Figure 10. This window provides the opportunity to export
the processor system into an ISE project as either the top level system or a sub-module design. We will leave the

settings as they are and implement the design using Xflow.

Project Options k @
Device and Repository  Hierarchy and Flow | HOL and Simulation I

Design Hierarchy

(® This is the toplewvel of my design
{ This is a sub-madule in my design

— Synthesis Toal

|IsE xaT x|

Implemeantation Tool Flow
@ XPS (<flow) (" ISE (ProjNav)

PowerPC Tutorial www.xilinx.com
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Figure 10: Project Options - Hierarchy and Flow
IV. Create — Import IP Peripheral

One of the key advantages of building an embedded system in an FGPA is the ability to include customer IP and
interface that IP to the processor. This section of the tutorial will walk through the steps necessary to include a
custom IP core.

In XPS, select Tools — Create/Import Peripheral to open the Create and Import Peripheral
Wizard.

Click Next. Select Create templates for a new peripheral.

By default the new peripheral will be stored in the project_directory/pcores directory. This enables
XPS to find the core for utilization during the embedded system development.

Click Next. In the Create Peripheral — Step 1 dialog, enter custom_ip as the name of the peripheral.
This is shown in figure 11.

Create Peripheral - Step 1

Name and Yersion o
Indicate the name and verzion of your peripheral. \

Enter the name aof pour peripheral. Thiz name will be uzed az the top HOL design entity.

M arme: |-:ustu:-m_ip

Werzion: 1.00.a
b ajor Revision Minor Revision Hardware/Software Compatibility Fevizion
- - -

Logical library name: custorn_ip_«1_00_a

AlHDL filez [either created by pou or generated by this tool] used to implement thiz
peripheral muzt be compiled into the logical ibram named above. Any ather logical libraries
referred to in wour HDL are asszumed to be available in the =PS project where this
peripheral iz uged, or in EDE repozsitaries indicated in the %P5 project settings.

Mare [nfo | < Back | Mext » Cancel

Figure 11: Create Peripheral — Step 1

In the Create Peripheral — Step 2 dialog, select On-Chip Peripheral Bus (OPB), as this is the bus to
which the new peripheral will be connected.

Click Next. The Create Peripheral — Step 3 dialog enables the selection of several services. For
additional information regarding each of these services, select More Info. Select the User Logic S/W
Register Support option.

14 www.xilinx.com EDK 7.1 PowerPC Tutorial in Virtex-4
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Create Periphernal - Step 3

Yaur peripheral will be connected to the OPB bus thraugh the OPE P interface [IFIF] madule.
Besides standard functions like addrezs decoding, thiz module alzo offers ather commanly uzed
zervices. Uzing theze services may significantly simplify the implementation of your penpheral.

IPIF Services NG
Indizate the IPIF zervices required by your penpheral. \

-

Attackhem ent + Controller |

sng jessyduad dup-ug

A Emmm m

¢ Back

5™ Beset and Module Information
regizter [FST/MIR]

Burzt Tranzaction Suppart

Dibd s

FIFO

Ilzer Logic [ntermpt Support

Ilzer Logic 5/ Reaister Support
I1zer Logic b aster Suppart

|1zer Logic Address Fange Support

Cancel

tare [nfo

| M et > |

Figure 12: Create Peripheral — Step 3

Click Next. In the Create Peripheral —Step 4 dialog change the Number of software accessible

registers to 4.

Create Peripheral - Step 4

Configure the software accessible registers in your peripheral.

The zoftware acceszible registers will be implemented in the uger-logic module of vour
peripheral. These reqisters are addreszable on the byte, half-ward ar word boundarnies. The
following fieldz determinge the characterniztics of the registers.

Mumber of zoftware accessible registers:

D ata wadth of each reqister; |32 j

Cancel

tare [nfo < Back | M et > |

User 5/Ww Register JQ

Figure 12: Create Peripheral — Step 4

PowerPC Tutorial
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Click Next. In the Create Peripheral —Step 5 dialog no additional signal changes are required.

Click Next. In the Create Peripheral —Step 6 dialog, a BFM simulation environment can be
generated. This tutorial will not cover BFM simulation. Leave the option unchecked.

Click Next. In the Create Peripheral —Step 7 dialog, uncheck the Generate ISE and XST project files
to help you implement the peripheral using XST flow.

Click Next and then Finish.

The Create / Import Peripheral Wizard creates a new directory called custom_ip_v1_00_a in the
pcores directory. This new directory contains the following:

Mame Size  Type
___FiIE Folder
[_idata File Falder
Jdewl File Folder
_ahdl File Folder
4 >

The following is a description of the files located in each directory:
- HDL source file(s)

MB_tutorial\pcores\custom_ip_v1_00_a\hdl

vhdl/custom_ip.vhd

This is the template file for your peripheral's top design entity. It configures and instantiates the
corresponding IPIF unit in the way you indicated in the wizard GUI and hooks it up to the stub user
logic where the actual functionalites should get implemented. You are not expected to modify this
template file except certain marked places for adding user specific generics and ports.

vhdl/user_logic.vhd

This is the template file for the stub user logic design entity, either in VHDL or Verilog, where the
actual functionalities should get implemented. Some sample code snippet may be provided for
demonstration purpose.

- XPS interface file(s)
MB_tutorial\pcores\ custom_ip_v1_00_a\data
custom_ip_v2_1 0.mpd

This Microprocessor Peripheral Description file contains information of the interface of your
peripheral, so that other EDK tools can recognize your peripheral.

custom_ip_v2_1_0.pao

This Peripheral Analysis Order file defines the analysis order of all the HDL source files that are
used to compile your peripheral.

16 www.xilinx.com EDK 7.1 PowerPC Tutorial in Virtex-4
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- Driver source file(s)
MB_tutorial\drivers\ custom_ip_v1_00_a\src:
custom_ip.h

This is the software driver header template file, which contains address offset of software
addressable registers in your peripheral, as well as some common masks and simple register access
macros or function declaration.

custom_ip.c
This is the software driver source template file, to define all applicable driver functions.
custom_ip_selftest.c

This is the software driver self test example file, which contain self test example code to test various
hardware features of your peripheral.

Makefile

This is the software driver makefile to compile drivers.

Now that the template has been created, the user_logic.vhd file must be modified to incorporate the
custom IP functionality.

Open user_logic.vhd. Currently the code provides an example of reading and writing to four 32-bit
registers. For the purpose of this tutorial, this code will not be modified.

Close user_logic.vhd.

In order for XPS to add the new custom IP core to the design, the pcores directory must be
rescanned. This can be accomplished by selecting Project » Rescan User IP Directories.

V. Design Modification using Platform Studio

Once a design has been created with the Base System Builder, it can be modified using the Add/Edit
Peripherals dialog. This dialog box allows the following design modifications for peripherals:

Add new peripherals

Change/update address map
Change/update peripheral parameters
Change/update peripheral ports

In XPS, select Project — Add/Edit Cores .. (dialog). This will open the Add/Edit Hardware
Platform Specifications dialog box, as shown in figure 13, used to modify an existing design.

PowerPC Tutorial www.xilinx.com 17
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AddfEdit Hardware Platform Specifications

Peripherals \Bus Eonnectinnsl ﬂ.ddresses] Parts ] Parameters

Cells with white backgrounds can be edited. To delete % Shaw Al Companent Filter
Ll | peripherals. choose one or more rows and click Delete. Fracessar (" i
" MicroBlaze Only ~
Petipheral Hii er |Instance | " PowerPC Only o
PPl _virkexd 1.00.a ppc40s_0 " Either Processar E e
jtagppc_cntlr 2.00.a jjtagppc_ﬂ B - o
Uz
proc_sys_reset 1.00.a reset_block " DCR  OFR o J
) o r
plbzopb_bridge 1.01.a jpllﬂnpb ©FSL ¢ PLR
opb_uartlite 1,00.b Rs232_Uart CME  Tiane o o
opb_gpio 3.00b v |LEDs_4Bi ~ OCM
oph_gpio 3.01.b j Push_Ruttons_Position
plb_emnc 2.00a _v|sRAM_256Kx32 EE?&S}II:TEQQ -
plb_bramn_if _crtlr | 1.00.b jpll:u_bram_if_cntlr_l bufg_module
bram_block. 1.00.a plb_bram_if_cntlr_1_bram << Add ch!pscnpe_!c:nn
chipscope_ila
wkil_bws_splic 1.00.a SRAM_256K:32_ukil_bus_spli... chipscope_oph_iba
dem_module 1.00.a derm_0 chipscope_plb_iba
= = Delete > @ chipscope_vio
~radule_ref
(custam_ip
- 2
dor_inte
dsbram_if_crtlr
fehafsl_bridge
fik_tirmer
isbrarm_if_cntlr
jtagppe_cnth
Imb_bramn_if_crtl
mch_opb_sdram
microblaze
mii_ta_rmii b
0K | Cancel Help

Figure 13: Add/Edit Hardware Platform Specifications - Peripherals

Select the custom_ip peripheral from the complete list of peripherals available to this project, as
shown in figure 13.

Click << Add to add the custom_ip peripheral to the project. The instance name for custom_ip
peripheral can be changed by clicking in the Instance name field.

Select the Bus Connections tab. Click in the box next to custom_ip_0 sopb, as shown in figure 14, to

connect the custom_ip peripheral to the OPB Bus. A connection is made once the

«_» s

S 1

the box.

ChipScope Pro cores are an example of a bus monitor.

« »

s’ is
dicates a slave device, “m” indicates a master device, “bm” indicates a bus monitor.

displayed in
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AddfEdit Hardware Platform Specifications @

Peripherals  Bus Connections \Addresses] Ports ] F‘arametersl

Click on zquares to make master, slave or master-slave (M, 5, M5] connections. Choose one or more buzes [use Shift or Chl). Click Add.
Right click on any bus instance (column header] for a contest meru.
— dor w29 w1 00 a A
Fril dzacm_v10_v1_00_b
ppcd05 0 mder dzacm_v10_v2_00_a
— feb w10 w1 00 &
ppc405_0 dplb M <<hdd | g 520 w1 0 b
. fel w20 2 00_a
ppc405 0 iplb " isocm_v10_v1_00_b 2

ppcdl5_0 dzocm

Choose the BERAM port to connect to the controller port.

ppc405_0 isocm Give a name ta the connection.

gpelle Uimfes Cntlr Part BR.AM Part: | Conneckar
plhZaph sder plb_bramn_if _crtlr... |plb_bram_if_crtlr_... j plb_bram_...
plb2opb zplb 3

plb2opb mopb L

R5232 Ulart sopb 2

LED=_4Bit sopb %

Puzh_Buttons_Position sopb :

SRaM_26Ekx32 splb g

b bram it crth 1 <ol . Other Transparent buz [point to point] connections
plb_brarm_if_cntlr_1 spl

cuzstom_ip_0 soph { Source Destination | Conneckor
plb sder PPc405_0 jtagppe  |jtagppe 0 jtageecd | ftagppe_0_0

(] 9 | Cancel Apply Help

Figure 14: Add/Edit Hardware Platform Specifications — Bus Connections

Select the Addresses tab to define an address for the newly added custom_ip peripheral. The address
can be assigned by entering the Base Address or the tool can assign an address. For the purpose of
this tutorial, the tool will be used to assign an address.

Click Generate Addresses. Click Yes in the Information dialog. Once it successfully generated the
address map click Ok.

Select the Ports tab. This tab is used to define connections between peripherals and the external
ports. Using the Ports Filter, select custom_IP_0 to display only the ports associated with the
custom_ip peripheral. You will notice that there is only one port for this peripheral, OPB_Clk.

Selct OPB_Clk and click << Add to add this port to the Internal Port Connections list.

Using the pulldown option for the newly added port select sys_clk_s to connect the OPB_Clk to
sys_clk_s.

Click OK to close the Add/Edit Hardware Platform Specifications dialog.

The design is now read to be implemented.
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VI. Implementing the Design

Now that the hardware has been completely specified in the MHS file, you can run the Platform Generator.
Platform Generator elaborates the MHS file into a hardware system consisting of NGC files that represent the
processor system. Then the Xilinx ISE tools will be called to implement the design for the target board. To generate

a netlist and create the bit file, follow these steps:

Start ISE by selecting Start » Programs - Xilinx ISE 7.1i - Project Navigator.

In ISE, select File » New Project to create a new Project Navigator project.

In the New Project dialog box shown in figure 15, browse to the XPS project directory and then

enter the Project Name, project_navigator.

Enter a Hame and Location for the Project

Project Mame: Project Location:

project_navigator D:SPPC_tutonalsproject_nawvigator

Select the tupe of Top-Level module far the Project

Top-Level Module Tepe:

HDL |

MHext > Cancel

Help

Figure 15: ISE New Project

Click Next. Configure the Device and Design flow as shown in figure 16. It should be noted that

these settings are consistent with the XPS project.
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Mew Project

Ed

Select the Device and Desighn Flow for the Project

Property Hame | Yalue |
Device Family YWirtemd
Device nodwfal 2
Package =t
Speed Grade 10

|

Top-Level Module Type HOL
Synthesiz Tool #5T WHDLMerilog]
Simulator b odelzim
Generated Simulation Language WHOL

¢ Back | M et = | Cancel Help

Figure 16: New Project — Device and Design Flow

Click Next. The tutorial will not include a new source file at this time.
Click Next. The tutorial will not include an additional source files at this time.
Click Finish.

In ISE, select Project » Add Source. Select the system.xmp file located in the XPS project directory.
Click Open. This will add the system.xmp file as a source file in the ISE project.

Select the system.xmp source file and double click on the View HDL Instantiation Template.

A warning message will be displayed because the netlists for the EDK project have not been created.
By clicking OK the netlists will be generated.

Once the process has completed the editor window will contain the instantiation template called
system_stub.vhd. Select File — Save As and save system_stub.vhd to the project_navigator
directory.

In ISE, select Project » Add Source. Select the system_stub.vhd in the project_navigator directory.
The Source Type is a VHDL Design File.

By adding system_stub.vhd to the Project Navigator project the hierarchy is updated as shown in
Figure 17.
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Sources in Project; |

E project_navigakor.ize
= £ wodvfa] 2-10EES
- @ sugtem_stub-structure [spstern_stub vhd]
E spztem [D:APPC_tukarialhaysten. smp)

N B2 Module WYiew | 08 Snapshaot Yiew |E] Libran “iew

Figure 17: Project Navigator Project Hierarchy

In ISE, select Project » Add Source. Select the system.ucf file in the <xps_project>\data directory.
Associate the system.ucf with system_stub.vhd

Select system_stub.vhd and double click on Generate Programming File to implement the design
and generate a bit file.
ISE will call XPS to generate the EDK to create the following directories:

o hdl - contains the vhdl files that define the processor system

o implementation — contains the NGC files

o synthesis — contains the projects and information from synthesizing the files in the hdl directory to
create those in the implementation directory
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VII. Defining the Software Design

Now that the hardware design is completed, the next step is defining the software design. There are two major parts
to software design, configuring the Board Support Package (BSP) and writing the software applications. The
configuration of the BSP includes the selection of device drivers and libraries.

Configuration of the BSP

Configuration of the BSP is done using the Software Platform Settings dialog. In XPS, select Project > Software
Platform Settings. This will open the Software Platform Settings dialog box as shown in Figure 18. The Software
Platform Settings dialog box contains three tabs. Each of these tabs is used to control all aspects of the BSP creation.
The Software Platform tab allows the user to select the following:

e Drivers: The driver and driver version for each peripheral can be selected. It should be noted that the driver
version is not related to the peripheral version.

e Libraries: Select the Xilinx libraries used in the software applications.

e Kernel and Operating Systems: Select the Kernel or Operating System to be used. The following Operating
Systems are supported:

¢ Standalone

¢ Xilinx MicroKernel

No changes are required on this tab.
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Software Platform Settings

Sottware Platfarm \ Proceszor, Driver Parameters and Interupt Handlers] Library/05 Parameters l

X

Libraries - To use a library, mark the check box

K.ermel and Dperating Systems

Driveers

Peripheral HWW Yer Inskance Driver | Version
ppcd0S_virkexd 1.00.a ppcd0s_0 CpuU_ppc40S ﬂ 1.00.a

plb_w34 1.02.a plb plbarb ﬂ 1.01.a
opb_w20 1.10.c opb opbarb ﬂ 1.02.a
plbZopb_bridge 1.01.a plbZopb plbZopb ﬂ 1.00.a
opb_uartlite 1.00.b RS232_Uark uarklite j 1.00.b
opb_gpio 2.0L.b LED=_4Bit gpio vlzooa |
opb_gpio 3.01.b Push_Buttons_Position | gpio ﬂ 2.00.a ﬂ
plb_emc Z.00.a SRAM_Z56KxIZ &mc ﬂ Z.00.a
plb_bram_if_cnklr 1.00.b plb_bram_if_cntlr_1 bram ﬂ 1.00.a
decm_rnodule 1.00.a dcrn_0O Qeneric ﬂ 1.00.a
cuskam_ip 1.00.a custom_ip_0 cuskam_ip ﬂ 1.00.a

Lse |Li|:urar~;.f Yersion | Prac Inst Q5 |OS Version
|_ xilnet 2.00.a3 ﬂ ppcds_0 standalone ﬂ 1.00.a
[ ximfs 1.00.a ﬂ
il 1.00.3 |
[ xfatfs 1.00.a |
i 2.00.3 |
lTl Cancel Help

Figure 18: Software Platform Settings Dialog

Select the Processor and Driver Parameters tab as shown below in Figure 19. This tab allows the user to configure
several Processor and Driver Parameters. No changes are required on this tab.
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Software Platform Settings §|

Software Platform  Processor, Driver Parameters and Interrupt Handlers I Library/05 F'arameters]

Proceszor Parameters

Instance Current Yalue | Default Yalue | Twpe | Descripkion
a cpu_ppc40s @ ppoc40S_0
";’;’ CORE_CLOCK_FREQ _HZ 300000000 400000000 ink Core Clock Frequency in Hz
";’;’ COMPILER powerpc-gabi-gec | powerpc-gabi-goc  string Compiler used ka compile both B3P, lib...
";’;’ ARCHIVER powerpc-eabi-ar | powerpc-gabi-ar  string Archiver used to archive libraries for ...
";’;’ EXTRA_COMPILER_FLAGS |[-g -g skring Extra compiler flags used in BSP and |i. ..

Driver Parameters and Global Interrupt Handlers

Instance Current Yalue Default Yalue | Twpe | Descripkion
";’? plbarb : plb
'v opbarb : opb
";’ plbZopb : plbZopb
" uartiee : RS232_Uart
"I apio ¢ LEDs_4Eit
"J gpio : Push_Buttons_Pasition

1] | Cancel Help

Figure 19: Processor, Driver Parameters and Interrupt Handler Settings

Select the Library/OS Parameters tab and configure the Library/OS Parameters tab as shown in
Figure 20. This allows the RS232 peripheral to be used for standard IO functions like print, printf,
scanf, etc. If the RS232 peripheral is already selected, no change is required.
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Software Platform Settings §|

Software Plalfnrm] Frocessor, Driver Parameters and Intermupt Handlers - Libra/05 Parameters l

Library and 05 Parameters

Instance Current Yalue | Default Yalue | Type | Description
=] S3 ppe405_0: standalone
£ enable_sw_intrusive_pra..,
'V enable_sw_intrusive_.., |false j False bool Enable 5/ Intrusive Profiing on Har. ..
"J profile_timer none nane petipher... Specify the Timer to use Far Profiling. ...
— -:b,', stdin R5232_Uark jnnne petipher... stdin peripheral
— 'V stdouk R323Z_|Jart jnnne petipher,.. stdout peripheral
— ";’;’ need_xil_mallac false j false baoal Is xil_malloc required 7
L -:b,', microblaze_exception_ve... | ((XEx... J (WEWC_UNALIG...  array Specify the handlers For the various e...

0k | Cancel Help

Figure 20: Library/OS Parameters
Click OK.

In XPS, select Tools > Generate Libraries and BSPs to run LibGen and create the BSP which
includes device drivers, libraries, configures the STDIN/STDOUT, and Interrupt handlers associated
with the design.

LibGen creates the following directories in the ppc405 0 directory, shown in Figure 21:
e code: contains the compiled and linked application code in an ELF file

e include: contains the header files for peripherals included in the design (such as xgpi 0. h and
xuartlite. h)

e lib: contains the library files (such as | i bc. a and | i bxi | . a)

e libsrc: contains the source files used to create libraries

Note: For more information on these files, refer to the Embedded System Tools Guide.
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Marme Size | Type
Cicode | File: Folder
Zinciude File Folder
i | o] File Folder
Cilibsre File Folder

Figure 21: PowerPC Drivers Directories

Building the User Application

In EDK 7.1, XPS provides the ability for the user to create multiple software projects. These projects can include source files,
header files, and linker scripts. Unique software projects allow the designer to specify the following options for each software

project:

Specify compiler options
Specify which projects to compile
Specify which projects to downloaded

Build entire projects

Software application code development can be managed by selecting the Applications tab as shown in Figure 22. The
Base System Builder (BSB) generates a sample application which tests a subset of the peripherals included in the

design.

=l =l

Syztern Applications

Right Click far Optionz

g Software Projects
Bﬁ“ Default ppcd05 0_bootloop
= BR‘,;“ Project: TestApp_Memory
+-[g Processor ppcd0S_0
Executable: 0:APPC_tutonalhTestépp_Memonhexecutable.
Compiler Optionz
Sources
Headers
roject: TestApp_Penpheral
Froceszor: ppcd05_0
Executable: 0:APPC_tutonialhTestipp_Pernpheralexecutab
Compiler Optionz
Sources

+ giﬁ +]--[+
T i [ [

][+

[ [ [ [ [

Headers

Figure 22: Applications Tab

Compiling the Code

Using the GNU GCC Compiler, compile the application code as follows:

Select Tools -» Build All User Applications to run powerpc-eabi-gcc. Powerpc-eabi-gcc
compiles the source files.
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x|
|

(Console Log)

Project Opened.

At Local date and time: Thu Apr 21 11:51:01 2005

Command xbash -g —c "cd Soygdrivesd- PPC_tutorial~s: ~“usr-sbin-make —f system.make program: exit." Started. ..

powerpc—eabi-goc —02 Testipp Peripheral-src/TestApp Peripheral .c -o Testipp Peripheral executable.elf ™
—W1l.-T -Wl,.TestApp Peripheral sroc-Testipp Peripheral LinkScr -g -I. /ppcd05_0<includes -L. ppcd05_0-1libs ~
powerpc—esbi-szize Testipp Peripheral~executsble.elf

text data =5 ec hex filename
1350 a0s 4096 6254 186e Testipp_Peripheralsexecutable elf
Done

| ‘ | \Uumnlﬁ Wamitiy ﬁ Eror [

Figure 23: XPS Output Window

VIIl. Downloading the Design

Now that the hardware and software designs are completed, the device can be configured. Follow these steps to
download and configure the FGPA:

Connect the host computer to the target board, including connecting the Parallel-JTAG cable and
the serial cable.
Start a hyperterminal session with the following settings:

e coml — This is dependant on the com port your serial cable is connected to.

e  Bits per second: 57600

e Data bits: 8
e Parity: none
e Stop bits: 1

e Flow control: none
Connect the board power.

In ISE, Select system_stub.vhd in the source window. In the process window double click on
Configure Device (iMPACT) under Generate Programming File.

This will initialize the BIT file with the software application selected in XPS and open iMPACT.
With iMPACT configure the FPGA using system_stub.bit located in the project_navigator directory.

After the configuration is complete, you should see a display similar to that in shown in Figure 24:

’fr ML300 - HyperTerminal
Fle Edit View <Cal Transfer Help _
b= B DB

—— Entering main() --

Starting MemoryTest for SRAM_256Kx32:
Running 32-bit test...PASSED!
Running 16-bit test...PASSED!
Running 8-bit test...PASSED!

—— Exiting main(} ——

Connected 0:00:08 Y¥T100 57600 8-N-1

Figure 24: Hyperterminal Output
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IX. Debugging the Design

Now that the device is configured, you can debug the software application directly via the JTAG PPC connections.
GDB connects to the PowerPC core through the JTAGPPC and the Xilinx Microprocessor Debug (XMD) engine
utility as shown in Figure 19. XMD is a program that facilitates a unified GDB interface and a Tcl (Tool Command

Language) interface for debugging programs and verifying systems using the MicroBlaze or PowerPC (Virtex-II Pro)

microprocessor. The XMD engine is used with MicroBlaze and PowerPC GDB (mb-gdb & powerpc-eabi-gdb) for

debugging. Mb-gdb and powerpc-eabi-gdb communicate with XMD using the remote TCP protocol and control the

corresponding targets. GDB can connect to XMD on the same computer or on a remote Internet computer.

To debug the design, follow these steps:

Select Options - XMD Debug Options

The XMD Debug Options dialog box allows the user to specify the connections type and JTAG

Chain Definition. Two connection types are available for PowerPC:

Simulator — enables XMD to connect to the PowerPC ISS.

Hardware — enables XMD to connect to the JTAGPPC peripheral in the hardware.
Select Save.

Select Tools = XMD.

inx_Software\EDKWbintntamad.

—debugdevice cpunr 1
onnecting to cable (Parallel Port — LPT1>.
hecking cable driver.
Drdiver windrvrb.sys version = 6.8.3.8. LPT base address = B378h.
ECP hase address = B778h.
ECP hardware iz detected.
ahle connection estahlished.
onnecting to cable (Parallel Port — LPI1} in ECP mode.
hecking cable driver.
Driver xpcddrur.sys version 1.8.3.8. LPT bhase address = B378h.
Cable Type = 1. Revision = E.
able connection established.

JIAG chain configuration

IR Length Part Hame
1414893 ] RC3IS2@A8
85045893 8 ACFBZ8

onnected to the JIAG MicroBlaze Debug Module <(MDM>

o of processors =
icroBlaze Processor 1 Cunflguratlun

ersion.

o of PC Breakp01nt

o of Head Adde-Data

o of Write Addr-sData Watchpoints.
Instruction Cache Support
Data Cache Support

onnected to “mb" target. id = @
Startlng GDB server for “mh" target Cid = B> at TCP port no 1234
HMDx “F

Executing Connect Cmd: connect mb mdm —cable type xilinx_parallel port LPT1 -

Figure 25: XMD Window

In XPS, select Tools » Software Debugger to open the GDB interface.

In GDB, select File » Target Settings to display the Target Selection dialog box as shown in

Figure 26. Click OK.
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Target Selection @
[}S ¥ Set breakpoint at 'main’
e Remate/TCP | {0 = v Setbreakpoint at ‘exit
Hostname:  [localhost ™ Setbreakpoint at
Bl 1234 I Display Download Dialog

I~ Use xterm as inferior's thy

Ok Cancel | ‘

b More Options

Figure 26: GDB Target Selection

In GDB, select File » Open...
Select executable.elf in the TestApp_Memory directory.
Tutorial Test Questions:

Do you see the C code or the assembly code?
Why can you not see the C code?

In GDB, select File » EXxit.

In the Applications window of XPS, double click on the Project: TestApp_Memory label.

zix=
Systern  Applications  |options | Symbolz ]

Right Click for Options
& Software Projects
X Default microblaze_0_bootloop
X Default microblaze_0_xmdstub
5 an
#-[B Processor micitblaze 0
B Executable: DAProjects\Demo\S3Testapplexecutable.
=B Compiler Optians
B Linker Script DWProjects\Demo\S3h TestApphsrch Tes
- B Mode: EXECUTABLE
B Stack Size:
- B Heap Size:
-.[@ Sources

- B DMProjects\Demo\S3TestapphsrchTestapp.c
-[B Headers

In the Optimization tab;
e Set the Optimization Level to No Optimization
e Select Create symbols for debugging (-g option).

Click OK.
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Set Compiler settings for the project: TestApp
Emviranment  Optimization lljkectories | Advancead |

Optimizetion Parameters

Optimization Level

Lewel 3is the most optimized lewsl.

| Use Global Pointer Optimization

l— f

For profiling xilprofile librany must be included in SW platfarm
Debug Options

("~ Do notgenerate debug symbols

(8 Create symbaols for debugging (-g option)

i Create symbols for assembly (-gstabs option)

MOTE: If an optimization level is set and -gis also set the
debug informeation may not be correlated to source code.

OK | Cancel

Recompile the code

Load the new executable.elf into GDB

Tutorial Test Question:
Do you see the Ccode? __ (If you do not see the C code, repeat the steps above.)

Select Run » Run

There is an automatic breakpoint at main. GDB allows you to single step the C or assembly code.

Note: The default values displayed in the Registers Window are in hex, while the values displayed in the
Source Window are in decimal.

X.  Performing Behavioral Simulation of the Embedded System

Performing a behavioral simulation of the complete system, which includes the embedded processor system, is a
powerful verification technique. In order to perform a behavioral simulation of the complete system in ISE, the
simulation file for the embedded system must be generated.

In XPS, select Options - Project Options. In the Project Options dialog box select the HDL and Simulation tab.
Browse to the precompiled EDK Library and Xilinx Library as shown in figure 27. It should be noted that the paths

will be different to match you system. For additional information on compiling the simulation libraries refer to the
Platform Studio User Guide Chapter 8.
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Device and Repositary ] Hierarchy and Flow  HOL and Simulation l

HOL Simulator Compile Script
(+ wHDL * modelSim ¢ MCzsim  Mone

Simulation Libraries Path

EDFE. Library [Output directary of compedklib]
|D:"-.MTI_Simulati-:nn_LiI:uraries_?1 SEDE_LIE

Hilire Libram [Qutput directany of compeib]
|D:'\MTI_Simulatinn_LiI:uraries_?1

If the libraries hawe not been compiled Compile

Simulation Models
{* Behavioral ¢ Structural © Timing

[v Allowe Mised Language Behavioral Files

| k. | Cancel Help

Figure 27: Project Options — HDL and Simulation tab

Click Ok. Select Tools » Generate Simulation HDL Files. This will generate all of the EDK HDL Simulation files

in the EDK\simulation\behavioral directory created by SimGen.

In order to simulate a design incorporating both EDK and ISE files, the simulation environments must be merged.

Copy the behavioral directory to the project_navigator directory.

Now that the EDK simulation files have been created and copied to the ISE directory, the ISE simulation

environment can be created.

In ISE, select system_stub.vhd and double click on Create New Source in the Process Window.

In the New Source dialog, select the source type as “VHDL Test Bench” and the File Name as “Testbench”

Click Next. Select system_stub as the source file to which the testbench will be associated.

Click Next and Finish. Testbench.vhd will now open in the ISE Editor Window.

Scroll to the bottom of the file and remove the following code:

tb : PROCESS

BEGIN
-- Wait 100 ns for global reset to finish
wait for 100 ns;

-- Place stimulus here

wait; -- will wait forever
END PROCESS;
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Add the following code:

tb_clk : PROCESS
BEGIN
sys_clk_pin <="'1"; wait for 10 ns;
sys_clk_pin <="'0"; wait for 10 ns;
END PROCESS;

tb_reset : PROCESS
BEGIN
sys_rst_pin <='0'; wait for 5 us;
sys_rst_pin <='1l"; wait;
END PROCESS;

fpga_0_RS232 Uart RX_pin <=fpga_0_RS232_Uart_TX_ pin;

In order to populate the BRAMs with the TestApp_Memory Application, a configuration statement must be utilized.
Add the following after the final “END;” statement in the Testbench.vhd file:

configuration tb_conf of Testbench_vhd is
for behavior
for uut: system_stub
for structure
for system_i : system
use configuration work.system_conf;
end for;
end for;
end for;
end for;
end tb_conf;

Save and close the Testbench.vhd file.

Select Testbench.vhd in the ISE Source Window. Right-click on “Simulate Behavioral Model” and select Properties...

In the Process Properties dialog box, specify the following settings as shown in figure 28:
- Check -> Use Custom Do File
- Select system_setup.do in the project_navigator\behavioral directory
- Uncheck -> Use Automatic Do File
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Figure 28: ISE Behavioral Simulation Process Properties

In the project_navigator/behavioral directory, open system_setup.do.
Add the following line as the first line in the file:

set tbpath "/testbench_vhd/uut"
cd behavioral

This is used to update the hierarchy used in the EDK simulation wave and list DO files.
Change the following command:
aliass "vsim -t ps testbench"
to:
aliass "vsim -t ps tb_conf"
Save and close the file.
Open system.do and add the following lines to the end of the file to compile the ISE files:

vcom -93 -work work ../system_stub.vhd
vcom -93 -work work ../testbench.vhd

Save and close the file.

Start the simulation by right-clicking on Simulate Behavioral Model and selecting “Run” and then “Open without
Updating”.

Once Modelsim opens the following commands are available:
c=> compile the testbench by running the EDK compile script.
Edit the testbench first before running this command.
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Assumes ISE and EDK libraries were compiled earlier
for ModelSim. (see system.do)

s=> load the testbench for simulation. (ModelSim 'vsim'
command with 'testbench') After loading the testbench,
set up signal displays (optional) and run the simulation.
(ModelSim 'run' command)

1=> setup signal list display and launch a list window.
ModelSim 'add -list' commands are found in * list.do
scripts. (see system_list.do)

w => set up signal wave display and launch a waveform window.
ModelSim 'add -wave' commands are found in *_wave.do
scripts. (see system_wave.do)

At the command prompt type “c” to compile the source
At the command prompt type “s” to load the simulation

At the command prompt type “w” to load the wave window

At the command prompt type “run 300us” to begin running the simulation. It will take several thousand US to run
the design to simulate the functionality of the design because of the printf routines.
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