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Use Vivado to build an Embedded System

Introduction

This lab guides you through the process of using Vivado to create a simple ARM Cortex-A9 based
processor design targeting the ZedBoard or Zybo board. Where the instructions refer to both boards,
choose the board you are using. You will use Vivado to create the hardware system and SDK (Software
Development Kit) to create an example application to verify the hardware functionality.

Objectives

After completing this lab, you will be able to:

e Create a Vivado project for a Zynq system

e Use the IP Integrator to create a hardware system
e Use SDK to create a standard memory test project
¢ Run the test application on the board

Procedure

This lab is separated into steps that consist of general overview statements that provide information on
the detailed instructions that follow. Follow these detailed instructions to progress through the lab.

This lab comprises 5 primary steps: You will create a top-level project using Vivado, create the processor
system using the Vivado IP Integrator, generate the top-level HDL and export the design to SDK, create a
Memory Test application in SDK, and finally, test in hardware.

Design Description

The purpose of the lab exercises is to walk you through a complete hardware and software processor
system design. Each lab will build upon the previous lab. The following diagram represents the completed
design (Figure 1).
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Figure 1. Completed Design

In this lab, you will use IP Integrator to create a processing system based design consisting of the
following (Figure 2):

e ARM Cortex A9 core (PS)

e UART for serial communication

e DDR3 controller for external DDR3_SDRAM memory
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Figure 2. Processor Design of this Lab

General Flow for this Lab

Step 1: Step 2: Step 3: Step 4: Step 5:
Create a Create Generate Create a Verify
project using Processor Top-Level |:> Memory |:> Functionality
Vivado System using HDL and TestApp in in Hardware
IP Integrator Export to SDK
SDK

In the instructions below;
{sources} refers to: C:\xup\embedded\2014_2 zynq_sources
{labs} refers to : C:\xup\embedded\2014 2 zynq_labs

Board support for the Zybo is not included in Vivado 2014.2 by default. The relevant files “zybo.zip” need
to be extracted and saved to: {Vivado installation}\data\boards\board_parts\zynq

These files can be downloaded from the XUP webpage where this material is also hosted
www.xilinx.com/university
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Create a Vivado Project Step 1

1-1.

Launch Vivado and create an empty project targeting the ZedBoard or the
Zybo and using the VHDL language.

1-1-1. Open Vivado by selecting Start > All Programs > Xilinx Design Tools > Vivado 2014.2 >
Vivado 2014.2
1-1-2. Click Create New Project to start the wizard. You will see the Create a New Vivado Project
dialog box. Click Next.
1-1-3. Click the Browse button of the Project Location field of the New Project form, browse to {labs},
and click Select.
1-1-4. Enter labl in the Project Name field. Make sure that the Create Project Subdirectory box is
checked. Click Next.
ﬁ"':.'_:. Mew Project @
Project Hame
Enter a name for your project and spedify a directory where the project data files will
be stored
Project name: | lab 1|
Project location: | C:/xup/embedded/2014_2_zyng_labs B
Create project subdirectory
Project will be created at: C:fxupfembedded2014_2 zyng_labs/lab1
Figure 3. Project Name Entry
1-1-5. In the Project Type form select RTL Project, and click Next
1-1-6. Inthe Add Sources form, select VHDL as the Target language and Mixed as the Simulator
language, and click Next
> www.xilinx.com/support/universit ZYNQ 1-3
& XILINX. P Y ©

Xup@xilinx.com
© copyright 2014 Xilinx



Use Vivado to build an Embe

dded System

Lab Workbook

éfl_.. Meww Project
Add Sources

Specify HDL and netlist Files, or directories containing HOL and netlist files, ko add to vour project, Create a
new source File on disk and add it to your project, ¥ou can also add and create sources later,

Index Marne Libr ary HOL Source For Location
add Files. .. ] [ Add Directaries. .. ] ’ Create File. ..
Scan and add RTL include files inko project
Copy sources inko project
add sources From subdirectories
Target lanquage: | WHDL — + | Simulataor language: | Mixed
[ < Back “ Mext > ¢ Finish

Cancel

=

Figure 4. Add sources to new project

1-1-7. Click Next two more times to skip Adding Existing IP and Add Constraints

1-1-8. In the Default Part form, select Boards, and depending on the board you are using, select
ZedBoard or Zybo and click Next.

( g New Project

It

Default Part

Specify Filter

Choose a default Xilinx part or board for your project. This can be changed later.

& Parts Vendor | Al -
& Boards Display Mame | All v
Board Rey | Latest -
Reset All Filters
Search:
’ ) ) ) Availab
Display Mame Vendor Board Rev Part IfO Pin Count  File Version I0Bs
o ligkninccomp |\ xch0iodgw0 1 00 [0 [io0 |
B MicroZed Board em.avnet.com e @ xc7z010cg400-1 400 1.0 100
B 7edBoard Zynqg Evaluation and Development Kit em.avnet.com d  xc7z020cg484-1 434 1.0 200
B Artix-7 ACT01 Evaluation Platform xilinx. com 1.0 % xc7a200tfhg675-2 678 1.0 400
B Kintex-7 KC705 Evaluation Platform xilinx. com 11 % xcTk325tFfg900-2 900 1.0 500
@ virtex-7 VC707 Evaluation Platform xilinx. com 1.1 % xcTun485tFg1761-2 1,751 1.0 700
B virtex-7 VC709 Evaluation Platform xilinx. com 1.0 @ xcFunB90tFo1761-2 1,751 1.0 as0
B 7YNQ-7 ZC702 Evaluation Board xilinx. com 1.0 % xc7z020cg484-1 434 1.0 200
B ZYNQ-7 ZC708 Evaluation Board ilinx. com 11 % xc7z045ffg200-2 900 1.0 362
4| 1] | O
[ < Back ” Mext = Einish

Figure 5. Boards and Parts Selection

1-1-9. Check the Project Summary and click Finish to create an empty Vivado project.
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Creating the System Using the IP Integrator

Step 2

2-1.

2-11.

2-1-2,

2-1-3.

Use the IP Integrator to create a new Block Design, add the ZYNQ
processing system block, and import the provided xml file for the board.

In the Flow Navigator, click Create Block Design under IP Integrator

Flow Navigator ks

W A opg
A ey

4 Project Manager
fﬁ; Project Settings
% Add Sources
1F 1P catalog

4 [P Integrator
F Create Block Design
¥ Open Block Design
Generate Block Design

Figure 6. Create IP Integrator Block Diagram

Enter system for the design name and click OK

e

g"‘ Create Block Design

,:o:, Please specify name of block design

Design name: | system

Directory: [z <Local to Project=

(04 I | Cancel

Figure 7. Create New Block Diagram

IP from the catalog can be added in different ways. Click on Add IP in the message at the top of

the Diagram panel, or click the Add IP icon & in the block diagram side bar, press Ctrl + 1, or
right-click anywhere in the Diagram workspace and select Add IP

& XILINX.

www.xilinx.com/support/university
Xup@xilinx.com

ZYNQ 1-5

© copyright 2014 Xilinx



Use Vivado to build an Embedded System

Lab Workbook

2-1-4,

2-1-5.

o Diagram X

#[]| &, system
o @ This design is empty. To get started, [ Add IP | from the catalog.
- & Ctrl+E
:‘—l: 4 Delete
D; = Ctrl+C
N ] Ctrl+V
'ﬁ,“, , Ctrl+F
Select Al Ctri+A&
- Add IP... Ctrl+1
IP Settings...
Validate Design F&

Create Hierarchy...

Create Comment

Create Port... Ctri+K
Create Interface Port... Ctri+L

& Qe G
Q &|wl

=

& Regenerate Layout
T Save as PDF File...

G

Figure 8. Add IP to Block Diagram

Once the IP Catalog is open, type “z” into the Search bar, find and double click on ZYNQ7
Processing System entry, or click on the entry and hit the Enter key to add it to the design.

Search: z (9 matches)

Name

iF Clocking Wizard

iF 1A (Integrated Logic Analyzer)
iF MicroBlaze

iF MicroBlaze Debug Maodule (MDM)
iF MicroBlaze MCS

iF SelectlO Interface Wizard

iF XADC Wizard

ik ZYNQ7 Processing System |

iF ZYNQ7 Processing System BFM

Select and press ENTER or drag and drop, ESC to cancel

Figure 9. Add Zynq block to the design

Notice the message at the top of the Diagram window that Designer Assistance available. Click
Run Block Automation and select /processing_system7_0

E= Diagram X | ] Address Editor

*[] | 4, system

o I_Q. Designer Assistance available. Fun Block Automation

{F Jprocessing_system7_0

Figure 10. Run block automation
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2-1-6. In the Run Block Automation window, leave the default settings, including Apply Board Preset

checked, and click OK

ﬁ” Run Block Automation

(oo |

and DDR. interfaces

previous configuration

Instance: /processing_system7_0

Make Interface External: FIXED _IQ, DDR

Apply Board Preset:
Cross Trigger In: Disable -
Cross Trigger Out: Disable -

H", Zynq7 block automation applies current board preset and generate external connections for FIXED_IO, Trigger

MOTE: Apply Board Preset will discard existing IP configuration - please unchedk this box, if vou wish to retain

ok [ Cancel

Figure 11. Block Automation settings

Once Block Automation has been complete, notice that ports have been automatically added for
the DDR and Fixed 10, and some additional ports are now visible. The imported configuration for
the Zynq related to the Zybo board has been applied which will now be modified.

processing_system?7_0

DDR <=
FIXED_IO<=
USBIND_0+5=

M_AXI_GPO<=
—M_AXI_GPO_ACLK ZYNQ? TTCO_WAVEQ_OUT
TTCO_WAVE1_OUT
TTCO_WAVE2_OUT
FCLK_CLKD
FCLK_RESETO_N

ZYNQ7 Processing System

Figure 12. Zynq Block with DDR and Fixed 10

| DDR

|—— > Fixep_io
Il
Il

ports

2-1-7. Double-click on the added block to open its Customization window.

Notice now the Customization window shows selected peripherals (with tick marks). This is the default
configuration for the board applied by the block automation.
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ﬁ Re-customize IP @
ZYNQ7 Processing System (5.4) '
ﬁ’) Documentation @ Presets || IP Location @ Import XPS Settings
Page Navigator < || Zyng Block Design Summary Repart
Zyng Block Design [
1O Pesipherals pove
PS-PL Configuration SR0 Setings Apphcation Processor Unit {(APU)
EEE [swor ]
e L a0
Peripheral IjO Pins M | zco )
(150} ;cn‘o ARM Corex A AR Corex A
cPU CPRU
MIO Configuration CAN T — é‘:‘::;z:;
UART 0 &40
UART 1 ; Ax]
Clock Configuration 1 ET-emm— -
“ Mux =) | [ ae Sncop Centes u [T 2=
o) S00 gl e o
DDR Configuration P . =+ o 1 512 KB L2 Cache and Controlitr | Perts
USB O N
- . USE 1 ocM 25 KB
SMC Timing Calculation ook [ csu e SRAM ‘
ENET 1 Central omponénts —
Interrupts Bank1 Iercenned *
MO FLASH Memery v
(53:18) Interfaces - DAP
L1 m Mermery Interfaces
= el || e w
— L 1 Mesmory
SMCT Inferconnect
Cﬂ:lﬂlcn
DM [Byne [EET=]E]
[ P Y
et | ‘:"’"" EEEE Processing System(PS)
5
ol 2lal g, IEIIIHE i DA | oty | RO | High Perfonmames e |
Mmmlm "5"‘- AXI (Ol | Al Sawﬂdbsm
Rl Stave SHA
Pods Perts

Programmable Logic(PL)

OK ] [ Cancel

Figure 13. Imported peripherals settings

2-2. Configure the processing block with just UART 1 peripheral enabled.

2-2-1. A block diagram of the Zynq should now be open again, showing various configurable blocks of
the Processing System.

At this stage, the designer can click on various configurable blocks (highlighted in green) and
change the system configuration.

Only the UART is required for this lab, so all other peripherals will be deselected.

2-2-2. Click on one of the peripherals (in green) in the IOP Peripherals block, or select the MIO
Configuration tab on the left to open the configuration form

2-2-3. Expand I/O peripherals if necessary, and ensure all the following 1/O peripherals are deselected
except UART 1.
i.e. Remove: ENETO
USB 0
SDO
Expand GPIO to deselect GPIO MIO
Expand Memory Interfaces to deselect Quad SPI Flash
Expand Application Processor Unit to disable Timer 0.
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| MIO Configuration

+

Bank 0 IO Voltage LVCMOS 3.3V ~ Bank 1 10 Voltage | LVCMOS 1.8V~

Search: | C.

Peripheral 10 Signal 10 Type Speed Pullup Direction
= Memory Interfaces

- D Quad SPI Flash
i [[] SRAM/NOR Flash

® ¢ |k k[P

[ [] NAND Flash
=t /O Peripherals
] ENET 0

- [C] ENET 1
-] usBo
-] use1
B[] spo

B[] sp1

B[] UART 0

B UART 1 MIO 48 .. 40 -
B[] rco ' '
E [ »c1

B [C] spio

B[] sPr1

B [C] cano

B[] cani

B

t GPIO
[t Application Processar Unit

= T ]

|:| Timer 1
Figure 14. Selecting only UART 1

2-2-4. Select the PS-PL Configuration tab on the left.
2-2-5. Expand GP Master AXI interface and deselect M AXI GPO interface.
2-2-6. Expand General > Enable Clock Resets and deselect the FCLK_RESETO_N option.
2-2-7. Select the Clock Configuration tab on the left. Expand the PL Fabric Clocks and deselect the
FCLK_CLKO option and click OK.
Click on the @| (Regenerate Layout) button and see the following block diagram.
processing_system7_0
- DDR - DDR
ZYNQ. FIXED_IO-=k FIXED_IO
ZYNQ7 Processing System
Figure 15. Updated Zynq Block
2-2-8. Click on the @| (Validate Design) button and make sure that there are no errors.
> www.xilinx.com/support/universit ZYNQ 1-9
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Generate Top-Level and Export to SDK Step 3

3-1.

3-1-1.

3-1-2.

3-1-3.

Generate IP Integrator Outputs, the top-level HDL, and start SDK by
exporting the hardware.

In the sources panel, right-click on system.bd, and select Generate Output Products ... and
click Generate to generate the Implementation, Simulation and Synthesis files for the design

Right-click again on system.bd, and select Create HDL Wrapper... to generate the top-level
VHDL model. Leave the Let Vivado manager wrapper and auto-update option selected, and click
OK

The system_wrapper.vhd file will be created and added to the project. Double-click on the file to
see the content in the Auxiliary pane.

I
X

Sources — O
A= e BE

—H Design Sources (1]

=gy system_wrapper - STRUCTURE|( systermn_wrapper.vhd) (1)
=} system_i - system (system.bd) (1)
—|-gli system - STRUCTURE (system.vhd) (1)

: -3¢ processing_system?7_0 - system_processing_system7_0_0 (system_processing_systermn7_0_0.xci)
HH I Constraints
+= Simulation Sources (1)

Hierarchy | IP Sources | Libraries | Compile Order

£t Sources | H Design Hierarchy
Figure 16. The HDL Wrapper file generated and added to the project

Notice that the VHDL file is already Set As the Top module in the design, indicated by the icon ss

You should have the block design open before you export the design to SDK. If it is closed then
open the block design by clicking on the Open Block Design under the IP Integrator sub-menu of
the Flow Navigator pane.

Select File > Export > Export hardware and click OK. (Save the project if prompted)

Note: Since we do not have any hardware in Programmable Logic (PL) and hence there is no
bitstream to generate, the Include bitstream option is not available.

i "

ia"" Export Hardware @

,'0‘, Export hardware platform for
"W software development tools

Indude bitstream

Export to: | &0 <Local to Project> =

[ ok | I Cancel

Figure 17. Exporting hardware
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3-1-4. Select File > Launch SDK leaving the default settings, and click OK

4L Launch SDK [

"‘, Launch software development tool

Exported location: | B0 <Local to Project> =

Workspace: | B0 <Local to Project: -

POk [ Cancel

Figure 18. Launch SDK

SDK should now be open. If only the Welcome panel is visible, close or minimize this panel to view the
Project Explorer and Preview panel. A Hardware platform project should have been automatically created,
and the system_wrapper_hw_platform_0 folder should exist in the Project Explorer panel.

75 Project Explorer 2 = B || gz system.hdf i3
g <f:>| T S
system_wrapper_hw_platform_0 Hardware Platform Specification
a (3 system_wrapper_hw_platform_0
[ ps7_init.c Design Information
[ ps7_init.h ]
@ psT_inithtml Target FPGA Dew_ce: ?%Clll:l
2 psT_inittcl Created With: Vivado 2014.2

& system.hdf Created On: Thu Jul 10 11:55:31 2014

Address Map for processor ps7_cortexa% 0

ps7_afi 0 Oxf3008000 O=f3008fff

psi_afil Oxf3009000 O=f3009fff

ps7_afi_ 2 0xf3002000 0=f300afff

psi_afi_3 O0xf300bO00 Oxf300bf f{
ps7_coresight_comp_0 Oxf 8800000 OxfB8B8fffff
ps7_ddr 0 O=00100000 Oxl1fffffff

ps7_ddrc 0 Oxf 8006000 Oxf8006£ff
psT_dev_cfg 0 O=f 8007000 Oxf80070ff
ps7_dma_ns OxfR004000 0=fa004f£1£
ps7_dma_s Oxf8003000 0xf8003fff

Figure 19. SDK C/C++ development view

The system.hdf file (Hardware Description File) for the Hardware platform should be open in the preview
pane. Double click system.hdf to open it if it is not.

Basic information about the hardware configuration of the project can be found in the .hdf file, along with
the Address maps for the PS systems, and driver information. The .hdf file is used in the software
environment to determine the peripherals available in the system, and their location in the address map.
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Generate Memory TestApp in SDK

Step 4

4-1. Generate memory test application using one of the standard projects

template.
4-1-1. In SDK, select File > New > Application Project

4-1-2,

Name the project mem_test, and in the Board Support Package section, leave Create New

selected and leave the default name mem_test_bsp and click Next. (Note that this application will

run on ps7_cortexa9 0 i.e. core 0 of the two processor cores available.)

F.

m Mew Project

Application Project

Create a managed make application project.

Project name:  memn_test

Uze default location
Chaxuptemnbilabsilablilabl . sdk\mem_test

default

Target Hardware

m

m

Hardware Platform: lsystem_wrapper_hw_platform_ﬂ v‘ INgw‘
Processor l?ps?_r_ortexag_ﬂ v‘
Target Software
Language: @ C (0 C++
05 Platform: standalone -
Board Support Package: @ Create Mew  mem_test_bsp

Use existing

'\‘.:.' Bac Mext = ‘ [ Cancel

Figure 20. Create new SDK application project

4-1-3. Select Memory Tests from the Available Templates window, and click Finish.
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Available Templates:

Dhrystone

Empty Application

Hello World

IwIP Echo Server

Peripheral Tests

SREC Bootloader

Kilkernel POSIX Threads Demo
Zyng DRAM tests

Zyng FSBL

Figure 21. Creating Memory Tests C Project

The mem_test project and the board support project mem_test_bsp will be created and will be
visible in the Project Explorer window of SDK, and the two projects will be automatically built. You
can monitor the progress in the Console panel.

4-1-4. Expand folders in the Project Explorer view, and observe that there are three projects -
hw_platform_0, mem_test_bsp, and mem_test. The mem_test project is the application that we
will use to verify the functionality of the design. The hw_platform includes the ps7_init function
which initializes the PS as part of the first stage bootloader, and mem_test_bsp is the board
support package.

{ Project Explorer &7 =0
=R-1
4 '[EC- mem_test
Fi q-,ff Binaries
- %5 mem_test.elf - [arm/le]
» [a Includes
» [= Debug
4 =L srC
+ [€] memory_config_g.c
+ [W memory_config.h
> @ memaorytest.c
+ [h| platform_config.h
- g platform.c
- [n platform.h
Tl Iscript.id
4 @ mermn_test_bsp
1 BS5P Documentation
¢ = psi_cortexad 0
| & Makefile
| Hp, system.mss
a 3 system_wrapper_hw_platform_0
[€ ps7_init.c
[€] ps7_init.h
i@ ps_init.html
1= ps7_init.tl
|5 system.hdf

Figure 22. The Project Explore view
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4-1-5. Open the memorytest.c file in the mem_test project (under src), and examine the contents. This
file calls the functions to test the memory.

Test in Hardware

Step 5

5-1. Make sure that the JP7 is set to select USB power. Connect the board with
a micro-usb cable and power it ON. Establish the serial communication
using SDK’s Terminal tab.

5-1-1. Make sure that the JP7 is set to select USB power, and JP5 is set to JTAG

5-1-2. Make sure that a micro-USB cable is connected to the JTAG PROG connector (next to the power
supply connector). Turn ON the power.

5-1-3. Selectthe & Terminal tah |f it is not visible then select Window > Show view > Terminal.

5-1-4. Click on i and if required, select appropriate COM port (depends on your computer), and
configure it with the parameters as shown.

m Terminal Settings

[

View Settings:
View Title: Terminal 1

Encoding: [50-8859-1

Connection Type:

Serial

Settings:

Port: COMT

Baud Rate: [115200

A

Data Bits: ’E
Stop Bits: ’1
Parity: ’ Mone

A

Flow Contral; ’None

1

Timeout (secl: 5

oK

|| Cancel

Figure 23. SDK Terminal Settings
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You can find the COM port from the Windows Device Manager, in this case, COM7:

4 --‘? Ports (COM B LPT)
Pl ? Dell Wireless 5560 H5PA+ Mini-Card Device Management (COM5)

75" ECP Printer Port (LPT1)

L 7" Intel(R) Active Management Technelogy - SOL (COM3)

Figure 24. COM ports in Windows control panel

5-2. Run the mem_test application and verify the functionality.

5-2-1. In SDK, select the mem_test project in Project Explorer, right-click and select Run As > Launch
on Hardware (GDB) to download the application, and will execute ps7_init, and then execute
mem_test.elf (user application).

B Project Explorer 532 Build Coenfigurations b
Make Targets 4
= &
T - | Index 3
4 = mem_test
: 9‘5'? Binaries Show in Remote Systems view
> B Eclljudes Profiling Tools 2
. ebu
= ? Convert To...
4 [ sIC =
. €] memery_config_g.c Run As » GiD-B 1 Launch on Hardware (GDE)
+ [ memory_config.h Debug As » | [©] 2Llocal C/C++ Application
+ [€) memorytest.c Profile As * | B 3 Remote ARM Linux Application
» [n] platform_config.h ~ R
- [g platform.c sam Run Configurations...
. [A platform.h Cornpare With 2
Tl Iscript.ld Restore from Local History...

%"' Run C/C++ Code Analysis

Figure 25. Launch Application

5-2-2. You should see the following output on the Terminal tab.

MOTE: This application runs with D-Cache disabled.As a result, cacheline request
s will not be generated
Testing memory region: ps7_ddr 0
Memory Controller: ps7_ddr
Base Address: ©x00100000
Size: @x1ff00000 bytes
32-bit test: PASSED!
16-bit test: PASSED!
8-bit test: PASSED!
Testing memory region: ps7_ram_1
Memory Controller: ps7_ram
Base Address: @xffffoooe
Size: OxP00RTedd bytes
32-bit test: PASSED!
16-bit test: PASSED!
8-bit test: PASSED!
--Memory Test Application Complete--

Figure 26. SDK Terminal Output
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5-2-3. Close SDK and Vivado by selecting File > Exit in each program.

Conclusion

Vivado and the IP Integrator allow base embedded processor systems and applications to be generated
very quickly. After the system has been defined, the hardware can be exported and SDK can be invoked
from Vivado. Software development is done in SDK which provides several application templates
including memory tests. You verified the operation of the hardware by downloading a test application,
executing on the processor, and observing the output in the serial terminal window.
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