Creating a custom IP block in Vivado 
Using ZedBoard: A Tutorial
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[bookmark: _Toc240469726]Introduction
This tutorial will guide you through the process of using Vivado and IP Integrator to create a custom AXI IP block in Vivado and modify its functionality by integrating custom VHDL code. We will be using the Zync SoC and ZedBoard  as a hardware platform.  For simplicity, our custom IP will be a multiplier which our processor will be able to access through register reads and writes over an AXI bus.

The multiplier takes in two 16-bit unsigned inputs and then it will output one 32 bit unsigned value. A single 32 bit writes to the IP will contain the two 16-bit inputs, separated by the lower and higher 16 bits. A single 32 bit read from the peripheral will contain the result from the multiplication of the two 16-bit inputs. The design is simple but it is a good example of integrating your own code into an AXI IP block. 


Objectives 
After completing this tutorial, you will be able to:
Create an embedded system design using Vivado and SDK flow
Configure the Processing System (PS)
Add a custom IP in the Programmable Logic (PL) section
Use SDK to build a software project and verify the  functionality in hardware.

Procedure 
This lab is separated into steps that consist of general overview statements that provide information on the detailed instructions that follow. Follow these detailed instructions to progress through the tutorial.
This tutorial comprises three stages (each consisting of  steps): You will create a top-level project using Vivado, create the processor system using the IP Integrator, add two instances of the GPIO IP, validate the design, generate the bitstream, export to the SDK, create an application in the SDK, and, test the design in hardware. You will then be able to profile the application and produce statistics that will help you understand the main bottlenecks of your application.
Requirements
The following is needed in order to follow this tutorial:
· Vivado w/ Xilinx SDK (tested, version 20144)
· Zedboard (tested, version D)
[bookmark: _Toc240469727]Part 1: Building a Zynq-7000 Processor Hardware
[bookmark: _Toc240469728]Introduction
In this part of the tutorial you create a Zynq-7000 processor based design and instantiate IP in the processing logic fabric (PL) to complete your design. Then you take the design through implementation, generate a bitstream, and export the hardware to SDK.
If you are not familiar with the Vivado Integrated Development Environment Vivado (IDE), see the Vivado Design Suite User Guide: Using the Vivado IDE (UG893).
[bookmark: _Toc240469729]Step 1: Start the Vivado IDE and Create a Project
1. Start the Vivado IDE (FIGURE 1) by clicking the Vivado desktop icon or by typing vivado at a terminal command line.



[image: ]Figure 1: Getting Started Page





2. From the Getting Started page, select Create New Project. The New Project wizard opens (FIGURE 2).
3. Click Next

[image: ]Figure 2: Create New Project Wizard

4. In the Project Name dialog box, type the project name and location. Ensure that Create project subdirectory is checked, and then click Next. 
5. In the Project Type dialog box, select RTL Project, then click Next.
6. In the Add Sources dialog box, ensure that the Target language is set to VHDL, then click Next.
7. In the Add Existing IP dialog box, click Next. 
8. In the Add Constraints dialog box, click Next. 
9. In the Default Part dialog box select Boards and choose “ZedBoard Zynq Evaluation and Development Kit”. Make sure that you have selected the proper Board Version to match your hardware because multiple versions of hardware are supported in the Vivado IDE. Click Next. 
10. Review the project summary in the New Project Summary dialog box before clicking Finish to create the project. 


[bookmark: _Toc240469730]Step 2: Create the Base Processing System
1. In the Flow Navigator, select Create Block Design.

[image: ]Figure 3: Create Block Design from Flow Navigator

2. In the Create Block Design popup menu, specify a name for your IP subsystem design.


                       [image: ]
   
Figure 4: Create Block Design Dialog Box


3. Right-click in the Vivado IP integrator diagram window, and select Add IP.

[image: ]
Figure 5: Add IP Option

4. Alternatively, you can click the Add IP link in the IP integrator diagram area. 

[image: ]
Figure 6: Add IP Link in IP Integrator Canvas
The IP Catalog opens. 

5. In the search field, type zynq to find the ZYNQ7 Processing System IP, and then press Enter on the keyboard. 

[image: ]
Figure 7: The IP Integrator IP Catalog

Because you selected the ZedBoard when you created the project, the Vivado IP integrator configures the design appropriately. 


In the Tcl Console, you see the following message:

create_bd_cell -type ip -vlnv xilinx.com:ip:processing_system7:5.2 processing_system7_1
INFO: [PS7-6] Configuring Board Preset zed. Please wait ......
There is a corresponding Tcl command for all actions performed in the IP integrator block diagram. Those commands are not shown in this document. See the Tcl Console for information on those commands.
6. In the IP integrator diagram header, click Run Block Automation.

[image: ]
Figure 8: Run Block Automation on Zync
The Run Block Automation dialog box opens, stating that the FIXED_IO and DDR interfaces will be created for the Zynq core.

7. Click OK. 

[image: ]
Figure 9: Zync7 Run Block Automation Dialog Box



After running block automation on the Zynq processor, the IP integrator diagram should look as follows:
[image: ]
Figure 10: Zynq Processing System after Running Block Automation
8. We will now reconfigure the ZYNQ7 Processing System. Double click on the ZYNC block diagram.
9. The Re-customize IP window will open as seen in Figure 11.
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Figure 11: Re-customizing the ZYNQ Processing System 
10. Click on the MIO Configuration panel to open its configuration form.
11. Expand the IO Peripherals on the right.
12. Uncheck ENET 0, USB 0, and SD 0, GPIO (GPIO MIO), leaving UART1 selected.
13. In the MIO Configuration panel, expand the Application Processing Unit and uncheck the Timer 0.
14.  From the Page Navigator, select “Clock Configuration” and open the “PL Fabric Clocks” tree as seen in Figure 12.
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             Figure 12: Clock Configuration 
15. Make sure that the FCLK_CLK0 is enabled (ticked) and that it is set for a frequency of 100 MHZ. This will be our AXI clock.
16. Now from the Page Navigator, select “PS-PL Configuration” and open the “GP Master AXI Interface” tree.
17. Tick the “M AXI GP0 interface” checkbox and enable it as seen in Figure 13.
                 [image: ]
                                                   Figure 13: Clock Configuration
18. Now click “OK” to close the Re-customize IP window.
19. We must now connect the FCLK_CLK0 output to the AXI clock input. To do this, click on the FCLK_CLK0 output and then click on the M_AXI_GP0_ACLK input. This will trace a wire between the pins and make the connection as seen in Figure 14.
Figure 13: Clock Configuration [image: ]
                                   Figure 14: processing_system7_0 connection
[bookmark: _Toc240469733]Part 2: Create the Custom IP
Introduction
In this part of the tutorial you will create a custom IP by using the “Create and Package IP” facility in Vivado.
1. With the base Vivado project opened, from the menu select Tools Create and package IP. A new window will appear as seen in Figure 15.

      [image: ]

                                     Figure 15: Create and Package New IP
2. When the  “Create and Package IP” wizard opens. Click “Next”.
3. On the next page (Figure 16), select “Create a new AXI4 Peripheral. Click “Next”.

[image: ]
                                           Figure 16: Create  a new AXI4 Peripheral
4. Now you can give the peripheral an appropriate name, description and location as seen in Figure 17.  Click “Next”.

[image: ]
                                                             Figure 17: Peripheral Details

5. On the next screen we can configure the AXI bus interface. For the multiplier we will use AXI lite, and it will be a slave to the PS, so we will stick to the default values shown on Figure 18.
[image: ]
                                                   Figure 18: Add Interface

6. On the last page, select “Edit IP” and click “Finish” as seen in Figure 19.

                        [image: ]
                                                           Figure 19: Create&Edit IP

7. At this point, the peripheral that has been generated by Vivado is an AXI Lite Slave that contains  4 x 32 bit read/write registers (as seen in Figure 20). We want to add our multiplier code to the IP and modify it so that one of the registers connects to the multiplier inputs and another to the output.

[image: ]
                                                               Figure 20: Summary of IP
Add the multiplier code to the peripheral
You can find the multiplier code on the web site of ENG3050. Download the “multiplier.vhd” file and save it somewhere, the location is not important for now.
Note that these steps must be done in the Vivado window that contains the peripheral we just created (not the base project that contains the PS).
1. From the Flow navigator, click “Add Sources”. In the window that appears (Figure 21) select “Add or Create Design Sources” and click “Next”.
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                                           Figure 21: Add Sources

2. On the next window, click “Add Files”

[image: ]

                                          Figure 22: Add Files

3. Browse to the “multiplier.vhd” file, select it and click “OK”.
4. Make sure you tick “Copy sources into IP directory” and the click “Finish”


[image: ]

                                                  Figure 23: Choosing the VHDL Code

5. The multiplier code is now added to the peripheral; however we still have to instantiate it and connect it to the registers.










Modify the Peripheral
At this point, your Project Manager Sources window should like the following:


                          [image: ]
                                          Figure 24: Project Manager

1. Open the branch “my_multiplier_v1_0-arch_imp”
2. Double click on the “my_multiplier_v1_0_S00_AXI_INST” file to open it.
3. The source file should be open in Vivado. Find the line with the “begin” keyword and add the following code just above it to declare the multiplier and output signal:
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4. Now find the line that says “ – Add user logic here” and add the following code below it to instantiate the multiplier:

[image: ]

5. Find this line of code “reg_data_out <= slv_reg1”; and replace it with “reg_data_out <= multiplier_out”.
6. In the process statement just a few lines above, replace “slv_reg1” with “multiplier_out”.
7. Save the file
8. You should notice that the multiplier.vhd” file has been integrated into the hierarchy because we have instantiated it from within the peripheral.

                                   [image: ]
                                                    Figure 25: Sources Hierarchy






9. Click on “IP File Groups” in the Package IP tab of the Project Manager.

[image: ]
                                                                       Figure 26: IP Groups



10. Click the “Merge changes from IP File Group Wizard” link.
11. The “IP File Groups” should now have a tick.


[image: ]

                                                                  Figure 27: IP File Groups

12. Now Click “Review and Package IP” as seen in Figure 28.

[image: ]
                                                       Figure 28: Review and Package IP

13.  A final window will appear as seen in Figure 29. Press “OK”
                                                             [image: ]
                                   Figure 29: Close the Project




The peripheral will be packaged and the Vivado window for the peripheral should be automatically closed. We should now be able to find our IP in the IP catalog. Now the rest of this tutorial will be done from the original Vivado window.




Add the IP to the Design

1. Click the “Add IP” icon

2. Find the “my_multiplier” IP and double click it.

[image: ]
                                          Figure 30: Search for my_multiplier


3. The block should appear in the block diagram and should see the message “Designer Assistance available.  Run Connection Automation”. Click the connection automation link,




[image: ]

                                      Figure 31: Run Connection Automation



4. In the window that appears, set Clock connection to “Auto” and click “OK”.

[image: ]
                                   Figure 32: Run Connection Automation (Auto)

5. The new block diagram should like this.


[image: ]
                                   Figure 33: The Final Block Diagram




6. Validate the design (choose Tools  Validate Design).
Generate HDL Design Files
You now generate the HDL files for the design.

1. In the Source window, right-click the top-level subsystem design and select Generate Output Products (FIGURE 34). This generates the source files for the IP used in the block diagram and the relevant constraints file.

[image: ]
Figure 34: Generate Output Products Option

2. The Manage Output Products dialog box opens. Click OK.

[image: ]

3. In the Sources window, select the top-level subsystem source, and select Create HDL Wrapper to create an example top-level HDL file (FIGURE 35). 

4. Click OK when the Create HDL Wrapper dialog box opens. 

[image: ]
Figure 35: Create HDL Wrapper
[bookmark: _Toc240469734]



Implement Design and Generate Bitstream
1. In Flow Navigator, click Generate Bitstream to implement the design and generate a BIT file. 

Note: If the system requests to re-synthesize the design before implementing, click No. The previous step of saving the constraints caused the flow to mark synthesis out-of-date. Ordinarily, you might want to re-synthesize the design if you manually changed the constraints, but for this tutorial, it is safe to ignore this condition (FIGURE 36).

[image: ]
Figure 36: Generate Bitstream

You might see a dialog box stating no implementation results are available. 

2. Click Yes. 

[image: ]
Figure 37: No Implementation Results Available Dialog Box


3. After the design implementation, click Open Implemented Design, (FIGURE 38). 
[image: ]
Figure 38: Bitstream Generation Completed
4. You might get a warning that the implementation is out of date. Click Yes.

[image: ]
Figure 39: Implementation Is Out-of-Date Dialog Box


[bookmark: _Toc240469735]Export Hardware to SDK
In this step, you export the hardware description to SDK. You use this in Part 2.
The IP integrator block diagram, and the Implemented design, must be open to export the design to SDK.

IMPORTANT: For the Digilent driver to install, you must power on and connect the board to the host PC before launching SDK.

[bookmark: _Toc240469736]Export to SDK
1. In the Flow Navigator, click Open Block to invoke the IP integrator design (FIGURE 40).

[image: ]
Figure 40: IP Integrator - Open Block Design
Now you are ready to export your design to SDK. 

2. From the main Vivado File menu, select Export Hardware for SDK (FIGURE 41). 
[image: ]
Figure 41: Export Hardware for SDK
The Export Hardware for SDK dialog box opens, ensure that Export Hardware, Include Bitstream, and Launch SDK are checked (FIGURE 42).

[image: ]
Figure 42: Export Hardware for SDK

[bookmark: _Toc240469737]Part 3: Build Zynq-7000 Processor Software
In this portion of the tutorial you will test the multiplier by printing results to the terminal via the UART (serial port).

[bookmark: _Toc240469738]Step 1: Start SDK and Create a Software Application
1. If you are doing this lab as a continuation of Part 1 then SDK should have launched in a separate window (if you checked the Launch SDK option while exporting hardware). 

2. From the SDK window Select File > New > Application Project (FIGURE 43). 
[image: ]
Figure 43: File->New->Application Project
New Project dialog box opens



3. In the Project Name field, type TestMultiplier, and click Next (FIGURE 44).

[image: ]
Figure 44: SDK Application Project



4. From the Available Templates, select Hello World (FIGURE 45) and click Finish.

[image: ]
Figure 45: SDK New Project Template
When the program finish compiling, you will see the following (FIGURE 46).

[image: ]
Figure 46: SDK Message


[bookmark: _Toc240469739]Step 2: Modify the Software Application
Now, you can either run the hello world application on the ZedBoard or test the multiplier!!.  If you want to test the multiplier then you need to modify the software application. 

1. From the Project Explorer, open the “TestMultiplier/src” folder. Open the “helloworld.c” source file.
2. Replace all the code in this file with the following code shown in Figure 47 (available on the webpage)

[image: ]

Figure 47: SDK Message












Step 3: Run the code on the FPGA


1. Download the bitstream into the FPGA by selecting Xilinx Tools > Program FPGA (FIGURE 48).
[image: ]
Figure 48: Program FPGA
This opens the Program FPGA dialog box.

2. Ensure that the path to the bitstream that you created is correct and then click Program.

Note: The DONE LED on the board turns blue if the programming is successful. 

3. Connect a terminal to see the results.














4. Choose Run  Run Configurations. A new window will appear as seen in Figure 49.
[image: ]
Figure 49: Run Configuration

5. Double Click on Xilinx C/C++ application (GDB) and a new configuration will be created along with its setting menu.
6. Make sure you have an application associated with your run configuration.
7. Click on Run.
8. You will see the following results on the terminal (Figure 50)
[image: ]
[bookmark: _GoBack]Figure 50: Run Configuration
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Step 2: Create an IP Integrator Design  
1. In the Flow Navigator, select Create Block Design.  



  



Figure 3: Create Block Design from Flow Navigator 



2. In the Create Block Design popup menu, specify a name for your IP subsystem design. 



 



Figure 4: Create Block Design Dialog Box 
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 Step 2: Create an IP Integrator Design 
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3. Right-click in the Vivado IP integrator diagram window, and select Add IP. 



  



Figure 5: Add IP Option 



4. Alternatively, you can click the Add IP link in the IP integrator diagram area. 



 



Figure 6: Add IP Link in IP Integrator Canvas 



The IP Catalog opens.  



5. In the search field, type zynq to find the ZYNQ7 Processing System IP, and then press Enter 
on the keyboard. 



 



Figure 7: The IP Integrator IP Catalog 



Because you selected the ZC702 board when you created the project, the Vivado IP 
integrator configures the design appropriately.   
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Figure 6: Add IP Link in IP Integrator Canvas 
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on the keyboard. 



 



Figure 7: The IP Integrator IP Catalog 



Because you selected the ZC702 board when you created the project, the Vivado IP 
integrator configures the design appropriately.   





http://www.xilinx.com/








image7.png
(2 matches)

Search: | Q- zynq
=T <5

Name Version AXH Status. License Vendor

4 ZNQ7 Processing System 52 AXi4-Stream, AXI4 Production Included  Xlimx, Inc.

& ZYNQ7 Processing System BFM 10 A4 Pre-prod... Purchase  Xilin, Inc.

< [ s

Select and press ENTER or drag and drop, ESC to cancel





image8.emf



 Step 2: Create an IP Integrator Design 



Embedded Processor Hardware Design www.xilinx.com  15 
UG940 (v 2013.2) June 19, 2013 



In the Tcl Console, you see the following message: 
create_bd_cell -type ip -vlnv xilinx.com:ip:processing_system7:5.2 
processing_system7_1 



INFO: [PS7-6] Configuring Board Preset zc702. Please wait ...... 



There is a corresponding Tcl command for all actions performed in the IP integrator block 
diagram. Those commands are not shown in this document. See the Tcl Console for 
information on those commands. 



6. In the IP integrator diagram header, click Run Block Automation. 



  



Figure 8: Run Block Automation on Zynq 



The Run Block Automation dialog box opens, stating that the FIXED_IO and DDR interfaces 
will be created for the Zynq core.  



7. Click OK. 



 



Figure 9: Zynq7 Run Block Automation Dialog Box 
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Figure 8: Run Block Automation on Zynq 
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Figure 31: Create HDL Wrapper  



Step 5: Assign Signals to Debug 
Now assign the signals to debug in the hardware. 



1. After generating the IP Integrator design, from the Flow Navigator click Run Synthesis 
(FIGURE 32). 



 



Figure 32: Run Synthesis Option 



Note: Running synthesis could take several minutes. 



2. After synthesis completes, in the Synthesis Completed dialog box, check the Open 
Synthesized Design option, and click OK. 



3. In the Debug window, you see a list of nets in the Unassigned Debug Nets folder.   
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7. In the main Vivado toolbar, click the Save Constraints button to save the design after you 
insert the debug cores, (FIGURE 39).  



  



Figure 39: Save Constraints Option 



Step 7: Implement Design and Generate Bitstream 
1. In Flow Navigator, click Generate Bitstream to implement the design and generate a BIT 



file. 



Note: If the system requests to re-synthesize the design before implementing, click No.  



The previous step of saving the constraints caused the flow to mark synthesis  
out-of-date.  



Ordinarily, you might want to re-synthesize the design if you manually changed the 
constraints, but for this tutorial, it is safe to ignore this condition (FIGURE 40).  



 



Figure 40: Generate Bitstream 



You might see a dialog box stating no implementation results are available.  



2. Click Yes. 



 



Figure 41: No Implementation Results Available Dialog Box 





http://www.xilinx.com/








image40.png
No Implementation Results Available





image41.emf



 Step 7: Implement Design and Generate Bitstream 



Embedded Processor Hardware Design www.xilinx.com  32 
UG940 (v 2013.2) June 19, 2013 



During implementation flow, messages in the Log window show the implementation of the 
debug cores .   



This step is required to synthesize the debug core modules so that they can replace the 
debug core black boxes that you added to the design previously (FIGURE 42).  



 



Figure 42: Messages 



After the debug cores are implemented, the rest of the implementation flow (commands 
such as opt_design, place_design, and route_design) follow as usual. 



3. After the design implementation, click Open Implemented Design, (FIGURE 43). 



 



Figure 43: Bitstream Generation Completed 



4. You can keep the synthesized design open if you want to debug more signals; otherwise 
close the synthesized design to save memory (FIGURE 44).  
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Figure 44: Close Synthesized Design Dialog Box 



5. You might get a warning that the implementation is out of date. Click Yes. 



 



Figure 45: Implementation Is Out-of_date Dialog Box 



6. In the implemented design, go to the Netlist window to see the inserted ILA and Debug 
Hub (dbg_hub) cores in the design (FIGURE 46). 



  



Figure 46: Implemented Design 



Step 8: Export Hardware to SDK 
In this step, you export the hardware description to SDK. You use this in Lab 2. 



The IP integrator block diagram, and the Implemented design, must be open to export the 
design to SDK.   



 
IMPORTANT: For the Digilent driver to install, you must power on and connect the board to the 



host PC before launching SDK. 
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Export to SDK 



1. In the Flow Navigator, click Open Block to invoke the IP integrator design (FIGURE 47).  



 



Figure 47: IP Integrator: Open Block Design 



Now you are ready to export your design to SDK.    



2. From the main Vivado File menu, select Export Hardware for SDK (FIGURE 48). 



   



Figure 48: Export Hardware for SDK 



The Export Hardware for SDK dialog box opens.   



If you want to go on to Lab 2 then ensure that Export Hardware, Include Bitstream, and 
Launch SDK are checked (FIGURE 49). Otherwise, you can leave the Launch SDK option 
unchecked. 



 



Figure 49: Export Hardware for SDK 



Conclusion 
In this lab you have: 
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Figure 47: IP Integrator: Open Block Design 



Now you are ready to export your design to SDK.    



2. From the main Vivado File menu, select Export Hardware for SDK (FIGURE 48). 



   



Figure 48: Export Hardware for SDK 



The Export Hardware for SDK dialog box opens.   



If you want to go on to Lab 2 then ensure that Export Hardware, Include Bitstream, and 
Launch SDK are checked (FIGURE 49). Otherwise, you can leave the Launch SDK option 
unchecked. 
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Figure 47: IP Integrator: Open Block Design 



Now you are ready to export your design to SDK.    



2. From the main Vivado File menu, select Export Hardware for SDK (FIGURE 48). 



   



Figure 48: Export Hardware for SDK 



The Export Hardware for SDK dialog box opens.   



If you want to go on to Lab 2 then ensure that Export Hardware, Include Bitstream, and 
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Chapter 3 



Lab 2: Using SDK and the Vivado IDE 
Logic Analyzer 



Introduction 
You can run this lab after Lab 1. Make sure that you followed all the steps in Lab 1 before 
proceeding. 



Step 1: Start SDK and Create a Software Application 
1. If you are doing this lab as a continuation of Lab 1 then SDK should have launched in a 



separate window (if you checked the Launch SDK option while exporting hardware). You can 
also start SDK from the Windows Start menu by clicking on Start > All Programs > Xilinx 
Design Tools > Vivado 2013.2 > SDK > Xilinx SDK 2013.2.  



When starting SDK in this manner you need to ensure that you in the correct workspace.  



2. You can do that by clicking on File > Switch Workspace > Other in SDK. In the Workspace 
Launcher dialog box in the Workspace field, point to the SDK_Export folder where you had 
exported your hardware from lab 1. Usually, this is located at 
..\project_name\project_name.sdk\SDK\SDK_Export. 



Now you can create a peripheral test application.  



3. Select File > New > Application Project (FIGURE 50).  



 



Figure 50: File >New > Application Project 
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5. From the Available Templates, select Peripheral Test (FIGURE 52) and click Finish. 



 



Figure 52: SDK New Project Template 



When the program finishes compiling, you see the following (FIGURE 53). 



 



Figure 53: SDK Message 
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